
Practical 1 
 

Define a simple services like Converting Rs into Dollar and Call it from different platform 

like JAVA and .NET  

 

Software Tools Required: 

 

● Code Editor: Visual Studio Code (VS Code) 

● API Testing Software Application: Postman 
● Framework: Express.js (web framework) 

● Runtime Environment: Node.js 
● Programming Languages: JavaScript (for Node.js and Express.js), Java, C# (for 

.NET) 
 

Downloads Required: 

      

● Node.js:  Node.js — Download Node.js® 
● JDK:    Java Downloads | Oracle India (x64 MSI Installer) 

● Dotnet SDK:   Download .NET 9.0 SDK (v9.0.101) - Windows x64 Installer 
● Postman:         Download Postman | Get Started for Free  

                                     (Create Account/ Log in with Google) 

 

After Downloading Node.js, JDK and Dotnet SDK, Set the Path in Environment Variable in 

User Variables > Path > Edit > New and Paste the Path for Node.js, JDK and Dotnet SDK 

 

Demonstration:  

 

 
 

Click OK to remaining opened Edit environment variable, Environment Variables and 

System Properties windows. 

 
Now check the versions that shows path is set for Nodejs, Java JDK and Dotnet SDK 

 

 
 

Here all versions are shown so path is set by checking versions for Nodejs, Java JDK and 

Dotnet SDK. 

https://nodejs.org/en/download/prebuilt-installer
https://www.oracle.com/in/java/technologies/downloads/#jdk23-windows
https://dotnet.microsoft.com/en-us/download/dotnet/thank-you/sdk-9.0.101-windows-x64-installer?journey=vs-code
https://www.postman.com/downloads/


1. Design the Currency Conversion Service:  

 

Create a simple API that takes an amount in Indian Rupees and returns the equivalent 

amount in US Dollars. You can use a simple formula for conversion, or you can fetch real- 

time exchange rates from a reliable source. 

 

Example API endpoint: 

 

POST/convert 

 

Request: 

 

"amount in rs”: 1000 

 

Response: 

 

{ 

 

"amount in usd": 14.5 

 

} 

 

 

2. Implement the Service: 

 

You can implement the service using any programming language and framework. For 

simplicity, let's use Node.js with Express in this example, 

 

i. Set up a Node.js Project 

Create a Project Directory 

Example: Directory Path: Documents in C Drive 

Create a Folder Name: Cloud_Computing_Pratical1 

C: \Documents\Cloud_Computing_Practical1 

Select the Directory Path, Cut (Backspace) and Type cmd and hit enter 

We will get inside the path now type the following commands 

⮚ mkdir currency-conversion-service : mkdir - Make directory  

⮚ cd currency-conversion-service       : cd – change directory 

⮚ npm init -y                                        : npm – node package manager initializes yes 

⮚ npm install express body-parser       : To create simple server & handle incoming 

requests 

 



 

Demonstration: 

 

Inside currency-conversion-service > this is the folder architecture after initializing npm and 

express body-parser.  

 

Now Open with VS Code 

 



JavaScript (for Node.js and Express.js) 

File Architecture: 

Create a file to implement the service with JavaScript Programming language  

 

Filename: server.js 

Code:  

const express = require('express'); 

const bodyParser = require('body-parser'); 

const app = express(); 

const port = 3000; 

app.use(bodyParser.json()); 

app.post('/convert', (req, res) => { 

    const amountInRs = req.body.amount_in_rs; 

    // Perform the conversion (use a real exchange rate or a fixed rate for simplicity) 

    const conversionRate = 0.0145; 

    const amountInUsd = amountInRs * conversionRate; 

    res.json({ amount_in_usd: amountInUsd }); 

}); 

app.listen(port, () => { 

    console.log(`Currency conversion service running on http://localhost:${port}`);  

}); 

Output:  

Click View > Terminal: 

PS C:\Users\Kishore\Documents\Cloud_Computing_Practical1\currency-conversion-service> node 

server.js 

Currency conversion service running on http://localhost:3000 

The Output is successful indicating the service is running on http://localhost:3000 

 

http://localhost:3000/
http://localhost:3000/


Demonstration: 

 

      

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Postman 

API Testing Software Application to Test the API 

Open Postman 

Send a POST Request: 

URL: http://localhost:3000/convert 

Body: Set the body to raw JSON and include: 

{ 

        “amount_in _rs”: 1000 

} 

Response: 

{ 

        “amount_in _usd”: 14.5 

} 

 

Demonstration: 

 

  

Successfully output retrieved in Postman to test API. 

Now, to call from 2 different platforms Java and .NET Programming Language. 

     

 

http://localhost:3000/convert


Java Programming Language 

1. Java Client: Implement a Java Client to call the currency conversion service. 

You can use libraries like HttpClient for making HTTP requests.  

Create folder name: Java_Client in Cloud_Computing_Practical1 

Demonstration: 

 

Open Java_Client and Open with VS Code 

 

 

Extension: Install Java in VS Code 

 

File Architecture: 

 



Filename: JavaClient.java 

Code: 

import java.net.URI; 

import java.net.http.HttpClient; 

import java.net.http.HttpRequest; 

import java.net.http.HttpResponse; 

import java.net.http.HttpRequest.BodyPublishers; 

import java.net.http.HttpResponse.BodyHandlers; 

 

public class JavaClient { 

    public static void main(String[] args) { 

        HttpClient client = HttpClient.newHttpClient(); 

        String uri = "http://localhost:3000/convert"; 

        String requestBody = "{ \"amount_in_rs\": 1000 }"; 

 

        HttpRequest request = HttpRequest.newBuilder() 

                .uri(URI.create(uri)) 

                .header("Content-Type", "application/json") 

                .POST(BodyPublishers.ofString(requestBody)) 

                .build(); 

 

        client.sendAsync(request, BodyHandlers.ofString()) 

                .thenApply(HttpResponse::body) 

                .thenAccept(System.out::println) 

                .join(); 

    } 

} 

Output: 

Click View > Terminal: 

PS C:\Users\Kishore\Documents\Cloud_Computing_Practical1\Java_Client> javac JavaClient.java 

PS C:\Users\Kishore\Documents\Cloud_Computing_Practical1\Java_Client> java JavaClient       

{"amount_in_usd":14.5} 

The Output is Successful that we called the server.js with making HTTP request 



Demonstration: 

 

 

The java command is used to run the compiled Java bytecode. It starts the JVM, loads the specified 

.class file, and then executes the main method of that class.  

1. Ensure you have a .class file: This file is generated by compiling a .java file using the javac 

command. 

2. Run the Java program: Use the java command followed by the name of the class (without the 

.class extension) to execute the program. 

Here JavaClient.class file will be created after running the program 

 

 

 

 

 



           .NET Programming Language 

2. .NET Client: Implement a .NET Client to call the currency conversion service. 

You can use HttpClient in C#.  

 

Create folder name: .NET_Client in Cloud_Computing_Practical1 

Demonstration: 

 
 

Open .NET_Client and Open with VS Code 

 

 

Extension: 4 Extensions needed to work in C# 

 

C# 

 

C# Snippet 

 

 

 



 

C# Dev Kit 

 

C# Extensions 

 
 

File Architecture: 

 

Click on View > Terminal and Type the following command 

⮚ dotnet new console 

⮚ dotnet restore 

Demonstration: 

 

After entering dotnet new console command the file architecture will generate the .NET Project with 

Program.cs file shown below. 

 

 



Filename: Program.cs 

 

Code: 

using System; 

using System.Net.Http; 

using System.Text; 

using System.Threading.Tasks; 

 

class Program 

{ 

    static async Task Main() 

    { 

        try 

        { 

            var client = new HttpClient(); 

            var apiUrl = "http://localhost:3000/convert"; 

             

            // Create the request body with correct JSON format 

            var requestBody = new 

            { 

                amount_in_rs = 1000 

            }; 

            var jsonRequestBody = System.Text.Json.JsonSerializer.Serialize(requestBody); 

 

            // Send an HTTP POST request to the API with the request body 

            var response = await client.PostAsync(apiUrl, new StringContent(jsonRequestBody, 

Encoding.UTF8, "application/json")); 

 

            // Check the response status code 

            if (response.IsSuccessStatusCode) 

            { 

                Console.WriteLine("Response Code: " + response.StatusCode); 

                Console.WriteLine("Response Body: " + await response.Content.ReadAsStringAsync());  

            } 

            else 

            { 

                Console.WriteLine("Error: " + response.StatusCode); 

                Console.WriteLine("Details: " + await response.Content.ReadAsStringAsync());  

            } 

        } 

        catch (HttpRequestException e) 

        { 

            Console.WriteLine("An error occurred: " + e.Message); 

        } 

    } 

} 

 

 

 



 

Output: 

Click View > Terminal: 

     PS C:\Users\Kishore\Documents\Cloud_Computing_Practical1\.NET_Client> dotnet run 

     Response Code: OK 

     Response Body: {"amount_in_usd":14.5} 

The Output is Successful that we called the server.js with making HTTP request 

  Demonstration: 

 
 

 

Conclusion: The Practical worked successfully after creating currency conversion in postman with 

javascript and calling with Java and .NET by HTTP Requests.  

 

 

---------------------------------------- 



Practical 2 

Create a Simple SOAP service.  

 

Software Tools Required: 

 

● Code Editor: Eclipse IDE  

● Build Automation Tool: Apache Maven 
● SOAP Testing Tool: SOAPUI 

● Framework: Apache CXF 
● Programming Language: Java  

 

 

Downloads Required: 
 

● Apache Maven: Download Apache Maven – Maven  

● JDK: Java Downloads | Oracle India (x64 MSI Installer) 
● Eclipse IDE: Eclipse downloads - Select a mirror | The Eclipse Foundation 

● SOAP Testing Tool: Download REST & SOAP Automated API Testing Tool | Open 

Source | SoapUI  (SoapUI Open Source) 

 
 

After Downloading JDK and Maven, Set the Path in Environment Variable in User Variables 
> Path > Edit > New and Paste the Path for JDK and Maven and check the versions for both 

in command prompt. 

 

Demonstration: 

 

Path Set 

 
 

Version checked in command prompt 

 
 

 

 

 

 

 

 
 

 

https://maven.apache.org/download.cgi
https://www.oracle.com/in/java/technologies/downloads/#jdk23-windows
https://www.eclipse.org/downloads/download.php?file=/oomph/epp/2024-09/R/eclipse-inst-jre-win64.exe
https://www.soapui.org/downloads/soapui/
https://www.soapui.org/downloads/soapui/


Java Programming Language 

           Project Name: SimpleSOAPService 

 

Step 1: Open Eclipse IDE, Create a Maven Project, Check – Create a simple project (skip 

archetype selection) and Click Next. 

 

 

 
 

 

Step 2: In New Maven Project window add the following details – Group id: com.example, 

Artifact Id: SimpleSOAPService and Version: 0.0.1- SNAPSHOT and click Finish 

 

 

 
 



Step 3: After creating the Maven project, update the pom.xml to include the necessary 

dependencies for Apache CXF and JAX-WS. Here’s the full pom.xml file. 

 

pom.xml 

<project xmlns="http://maven.apache.org/POM/4.0.0" 

xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 

xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 

https://maven.apache.org/xsd/maven-4.0.0.xsd"> 

  <modelVersion>4.0.0</modelVersion> 

  <groupId>com.example</groupId> 

  <artifactId>SimpleSOAPService</artifactId> 

  <version>0.0.1-SNAPSHOT</version> 

  <dependencies> 

        <!-- Apache CXF for JAX-WS --> 

        <dependency> 

            <groupId>org.apache.cxf</groupId> 

            <artifactId>cxf-rt-frontend-jaxws</artifactId> 

            <version>3.4.5</version> 

        </dependency> 

 

        <!-- Apache CXF HTTP Transport --> 

        <dependency> 

            <groupId>org.apache.cxf</groupId> 

            <artifactId>cxf-rt-transports-http</artifactId> 

            <version>3.4.5</version> 

        </dependency> 

 

        <!-- Apache CXF HTTP Jetty Transport (for embedded HTTP server) --> 

        <dependency> 

            <groupId>org.apache.cxf</groupId> 

            <artifactId>cxf-rt-transports-http-jetty</artifactId> 

            <version>3.4.5</version> 

        </dependency> 

 

        <!-- Jakarta XML WS (JAX-WS API) --> 

        <dependency> 

            <groupId>jakarta.xml.ws</groupId> 

            <artifactId>jakarta.xml.ws-api</artifactId> 

            <version>2.3.3</version> 

        </dependency> 

 

        <!-- Java Annotations --> 

        <dependency> 

            <groupId>javax.annotation</groupId> 

            <artifactId>javax.annotation-api</artifactId> 

            <version>1.3.2</version> 

        </dependency> 

    </dependencies> 

</project> 

 

After adding dependencies Save it by Ctrl+S 

 



 

Step 4: Create the Service Interface 

Now, create a simple SOAP service interface to define the operations. 

1. Right-click on src/main/java → New → Package and name it com.example 
 

 
 

 

 
 

1. Right-click on the com.example package → New → Class and name it 

CalculatorService.java. 
 

 
 
 

 



 

 
 

File Name: CalculatorService.java 

 

Code: 

package com.example; 

 

import javax.jws.WebMethod; 

import javax.jws.WebService; 

 

@WebService 

public interface CalculatorService { 

 @WebMethod 
 int add(int num1, int num2); 

 

 @WebMethod 

 int subtract(int num1, int num2); 

} 

 

Save it 

 

 

 

 

 

 

 

 



 

 

Step 5: Implement the Service 

Now, create a class that implements the CalculatorService interface. 

1. Right-click on com.example → New → Class and name it 

CalculatorServiceImpl.java. 
2. Add the following code to CalculatorServiceImpl.java: 

 
File Name: CalculatorServiceImpl.java 

 

Code: 

package com.example; 

 

import javax.jws.WebService; 

 

@WebService(endpointInterface = "com.example.CalculatorService") 

public class CalculatorServiceImpl implements CalculatorService { 

 
    @Override 

    public int add(int num1, int num2) { 

        return num1 + num2; 

    } 

    @Override 

    public int subtract(int num1, int num2) { 

        return num1 - num2; 

    } 

}     Save It 

 

Step 6: Create the SOAP Server 
Next, create a class to publish the SOAP service. 

1. Right-click on com.example → New → Class and name it SOAPServer.java. 
2. Add the following code to SOAPServer.java: 

 

File Name: SOAPServer.java 

Code:  package com.example; 

 

import javax.xml.ws.Endpoint; 

 

public class SOAPServer { 

    public static void main(String[] args) { 

        // Create an instance of the service implementation 

        CalculatorServiceImpl implementor = new CalculatorServiceImpl(); 
 

        // Publish the service 

        String address = "http://localhost:8080/CalculatorService"; 

        Endpoint.publish(address, implementor); 

 

        System.out.println("SOAP Service started at " + address); 

    } 

}    Save It 

     

 



Output: 

 

mvn clean install: The clean install command is commonly used in Maven to build and 

install a project. The purpose of running clean is to remove any previously compiled code or 
artifacts, ensuring that the next build starts fresh without using any old files that might cause 

conflicts or errors. 

 
 

In Goal type clean install and run 

 

 
 

 
 

 

 

 



Run the Application 

1. Right-click on SOAPServer.java → Run As → Java Application. 
2. You should see the following output: 

 

SOAP Service started at http://localhost:8080/CalculatorService 

 

 
 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://localhost:8080/CalculatorService


Step 7. Test the SOAP Service Using SOAPUI 

 

1. Open SOAPUI and create a new project: 
1. Click File → New SOAP Project. 
2. In the Project Name field, enter CalculatorService. 
3. In the Initial WSDL field, enter: 

http://localhost:8080/CalculatorService?wsdl 
 

 

SOAPUI: 

 

 
 

 
 

 

 

 
Click OK 

 

 

 



SOAPUI will import the WSDL and display the operations (add and subtract). You can now 

test the SOAP service by right-clicking on the operations and sending requests. 

 

 
 

 

 
 

add > Request 1 

Here, in add we got the request and edited 5 and 2 in argument tags and output displayed in 

xml.  

 

 
 

 

 



subtract > Request 1 

Here, in subtract we got the request and edited 22 and 5 in argument tags and output 

displayed in xml. 

 

 

 
 

 

Conclusion: Why Use SoapUI to Create SOAP Services and Get Output in XML for Add 

and Subtract Operations 

 

SoapUI is a popular tool for testing and interacting with SOAP (Simple Object Access 

Protocol) web services. It is used to create and test SOAP services, allowing developers and 

testers to ensure that their web services function correctly and handle various input scenarios. 

Logic to Work with SOAP Services in SoapUI: 
 

Creating SOAP Service: 

● WSDL (Web Services Description Language): SoapUI uses the WSDL file to 

generate the request and response structure for SOAP services. The WSDL defines 

the operations, input/output messages, and service endpoint. 
● SOAP Request and Response: In SoapUI, you can create SOAP requests based on the 

operations defined in the WSDL. For operations like "Add" and "Subtract," the SOAP 

request will include the parameters (e.g., two numbers) to be processed by the web 

service. 
 

------------------------------- 



     Practical 3 

Create a Simple REST Service 

Software Tools Required: 

• Code Editor: Visual Studio Code (VS Code) 

• API Testing Software Application: Postman 

• Framework: Flask (micro web framework) 

 

Downloads Required: 

 

• Python:           Download Python | Python.org 

• Postman:         Download Postman | Get Started for Free  

                                     (Create Account/ Log in with Google) 

 
After Downloading Python, Set the Path in Environment Variable in User Variables > Path > 

Edit > New and Paste the Path for Python. 

 

New version is 3.13, Here the version is 3.12 so following the same for new version. 

 

Till Python312: Copy Directory Path 

Start > Python 3.13.1 (64 bit) > Open File Location > Python 3.13.1 (64 bit) 

 

Till Python312\Scripts: Copy the Directory Path 

Start > Python 3.13.1 (64 bit) > Open File Location > Python 3.13.1 (64 bit) > Open File 
Location > Scripts  

 

Demonstration: 

 

 
 

Check Version: 

 

 

 

 

 

 

 

https://www.python.org/downloads/?form=MG0AV3
https://www.postman.com/downloads/


Python Programming Language 

    

 

Step 1: Install Flask: Make sure you have Python installed on your system. 

Open cmd and type the following command 

 

pip install Flask 

Demonstration: 

 

 

 

Step 2: Create a folder name SimpleRESTService, Open with VS Code and create python 

file. 

 

Check and Install Extensions for Python 
 

Extensions: 

 

Python 

 

 
 

Python Debugger 

 

 
 

 

 

 

 



 

Filename: app.py 

 

Code: 

from flask import Flask, jsonify, request 

app = Flask(__name__) 

 

# Sample data 

data = [ 

    {'id': 1, 'name': 'Item 1'}, 

    {'id': 2, 'name': 'Item 2'}, 

] 

 

# Endpoint to get all items 

@app.route('/items', methods=['GET']) 

def get_items(): 

    return jsonify({'items': data}) 

 

# Endpoint to get a specific item by ID 

@app.route('/items/<int:item_id>', methods=['GET']) 

def get_item(item_id): 

    item = next((item for item in data if item['id'] == item_id), None) 

    if item: 

        return jsonify({'item': item}) 

    else: 

        return jsonify({'message': 'Item not found'}), 404 

 

 

 

 

 



 

# Endpoint to add a new item 

@app.route('/items', methods=['POST']) 

def add_item(): 

    new_item = {'id': len(data) + 1, 'name': request.json['name']} 

    data.append(new_item) 

    return jsonify({'message': 'Item added successfully', 'item': new_item}), 201 

 

# Run the application 

if __name__ == '__main__': 

    app.run(debug=True) 

 

Output: 

View>Terminal 

Type  

Path> python app.py 

Demonstration: 

 

 

 

 

 

 

 

 

 



Postman 

API Testing Software Application to Test the API 

Open Postman 

# Endpoint to get all items 

Send a GET Request: 

URL: http://127.0.0.1:5000/items 

Response: 

{ 

    "items": [ 

        { 

            "id": 1, 

            "name": "Item 1" 

        }, 

        { 

            "id": 2, 

            "name": "Item 2" 

        } 

    ] 

} 

Demonstration: 

 

 

http://127.0.0.1:5000/items


 

# Endpoint to get a specific item by ID 

Send a GET Request: 

URL: http://127.0.0.1:5000/items/1 

Response: 

{ 

    "item": { 

        "id": 1, 

        "name": "Item 1" 

    } 

} 

Provides specific id from Sample Data available i.e., URL:  http://127.0.0.1:5000/items/1 

Demonstration:  

          

Throws Error when not item not found from Sample Data. Example  

URL: http://127.0.0.1:5000/items/100 

Demonstration:  

 

http://127.0.0.1:5000/items
http://127.0.0.1:5000/items/1
http://127.0.0.1:5000/items/100


 

# Endpoint to add a new item 

Send a POST Request: 

URL: http://127.0.0.1:5000/items 

Body: Set the body to raw JSON and include: 

{"name":"item3"} 

Response: 

{ 

    "item": { 

        "id": 3, 

        "name": "item3" 

    }, 

    "message": "Item added successfully" 

} 

Demonstration: 

 

 

    --------------------------------- 

http://127.0.0.1:5000/items


   

 

 

Create a Simple SOAP service. 

Practical-1 
 

 
Steps: 

1] Open the NetBeans , and you will get the following screen. Close the start page. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2] Now click on the file tab and click on new project you will get the following screen : 



   

 

 

3] In Categories select Java Web and in Projects , Select Web Application .After selecting click onnext . 

You will get the following window: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
4] Now Give name to the Project Name: , and click on next . you will get the following windowthen 
. again click on finish: 



   

 

 

5] You will get the following screen now carefully see in projects section your recently created project 

appears double click to expand it: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  
6] Now Right click on the project and select new and then select Web Service ,As shown Below: 



   

 

 

7] after clicking Web Service following window should appear , now give name to web serviceand 
give package as “server”. As shown in the image: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
After clicking finish you should get the following window erase the mentioned code : 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

8] Now right click any where and click on insert code and select Add Web Service Operation : 



  

10] give the name to the variable select data type as double and click on ok as shown below: 

 

 

 
 
 
 
 
 
 
 
 
 

 
9] the following window would appear : 

Just give name to the method or operation and click on add button to add parameters to the method as 

here we are converting dollar to rupees we should need only one parameter . 



  

 

13] now right click on webservice and click on test web service you will get the following output: 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
11] After clicking ok code will autogenerate , make changes In that code as mentioned below: 

 
 
 
 
 
 

 
12] now our web service is ready now right click on project and click on deploy : 



  

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
So this is how we created our web service and deployed it. 



  
 

 

15] give name and click on finish as shown below do it 2 times on for input and one foroutput: 

 

 

Creating a java Client using jsp 

 
14] now our web service is successfully deployed. Right click on web pages and select new and 

select jsp as shown below: 
 

16] In input.jsp create a form for taking user input as shown below: 



 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
In this code set action = the jsp file where u want output and give name to textbox input. 

 

 
17] now we have to create web service client, for same right click on project and select new then 

select web service client you will get the following screen: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
At this step click on browse and select your project and click ok after clicking ok you will get wsdl url as 

shown below: 



 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
At this stage copy the url and paste it in notepad for future. 

Give package name as “Client”. 

Now click on finish. 
 

 
18] now in project section you can se a new folder is been created named “web servicerefrence”. 

double click to expand it you should get the following : 



 

 

 

Hold the operation or your operation name and drag it into the output.jsp in body tag as shown 

: You will get the following auto generated code: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

19] now make changes as shown below in the code: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
20] now Deploy our project again and right click on input.jsp and click run file you will redirect to a 

browser page as shown : 
 



l 

 

 

Enter any numerical value in text box and click on submit you will get the following output: 
 

 



  

 

 

 

 

 

Python client: 
 

 
 

 
1] for consuming java web services in python we should repeat the above steps till step np.19 . 

Note: for getting output the project or web service should be deployed . 

After doing all of the steps write the following code in python idle: 

Code : 
 

 
from zeep import Client 

wsdl_url='http://localhost:8080/pract/Currency?wsdl' 

client=Client(wsdl_url) 

#call the method on the webservice 

d=float(input("Enter Currency in Indian Rupees:")) 

result = client.service.InrtoDollar(d) 

print(result)2] replace wsdl_url with the url which was copied at the time of web service client 

creation . 

In step no.17 . and replace the InrtoDollarwith your method or operation name. and pass parameter 

to it 

3] final code should look like following: 
 
 
 
 
 
 
 
 
 

 
4] after running the above code you should get the following output: 

 



  

  

 

 

 

 

.Net Client 
 

1] open visual studio and select create a new project the following window will appear: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Here in search bar type “console c#” and select console app for .Net frame work as shown in 

above image. 

2] Give name to the project and press create button as shown in the image: 



 i   

  

 

 

 

 
 

 
This window should appear after clicking create button now In right side there is solution Explorer. 

In that right click on your project name and click on add > Service Reference . You will get the 

following window : 

Note: before executing the code make sure that the web service is deployed. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Here in address bar paste the wsdl url the same which is used I python code. And press go button . agter 

set the namespace In my case I am letting is as it is then press ok button. 

In following image u can check in solution Explorer service refrence iscreated.: 

https://www.youtube.com/%40cscornersunitarai


    

  

 

 

 

 

Using your_projectname . your_serviceReference_name ; 

4] now write the code as shown in the following image: 

3] now in code write the following line as shown in image: 

Here type: 



   / 

  

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Note: 

Here CurrencyClient is my webservice class name and operation() is my method name as show 

you can also check your own: 

 
 
 

 
5] when you run the above code you get the following output: 

https://study.cscornersunitarai.com/


   / 

  

 

 

1] create a new project and create a new webservice 

2] now right click on the code and click on insert code > add new web service operation 

3] after give name to operation FtoC and add one parameter a of double data type and click ok 

the code will auto generate . 

4] now do the following changes in that auto generated code: 

Now deploy the model. 

5] After deploying the model just right click on your web service and click on test web service . and 

you will get redirected to a browser page where you can check that your web service is working or 

not. 

Creating java Client using jsp 

5] now right click on web pages > new > jsp . and give name as input jsp. 

Again right click on web pages > new > jsp . and give name as output jsp. 

 
Practical-2 

 

Steps: 

Note : for all these steps in brief refer practical no.1 document 
 

6] In input.jsp write the following code : 

Define a simple services like Converting Rs into Dollar and Call it from different 

platform like JAVA and .NET 

https://study.cscornersunitarai.com/


   / 

  

 

 

to web service references and drag and drop the operations in output.jsp in body tag as shown 
below: 

8] now deploy the model again and run the input.jsp file you will get redirected to the browser page 
as shown: 

 

 

7] create a Web service client and give package name as “Client”. After creating web service client go 
 

After submitting you will get the following output: 

https://study.cscornersunitarai.com/
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Python Client 

 

 
1] Deploy the web service and write the following code : 

Code : 
 

 
from zeep import Client 

wsdl_url='http://localhost:8080/Practical_2/TempConverter?wsdl' 

client=Client(wsdl_url) 

#call the method on the webservice 

d=float(input("Enter temperaure in Fahrenheit :")) 

result = client.service.FtoC(d) 

print(result) 

2] replace your_wsdl_url with the url which was copied at the time of web service client creation . 

In step no.16 . and replace the operation_name with your method or operation 

name. and pass parameter to it 

3] final code should look like following: 

https://study.cscornersunitarai.com/


    

  

 

 

 
 
 

 
.Net Client 

1] open visual studio and select create a new project the following window will appear: 

 

 

4] after running the above code you should get the following output: 



    

  

 

 

Here in search bar type “console c#” and select console app for .Net frame work as 

shown in above image. 

2] Give name to the project and press create button as shown in the image: 
 

This window should appear after clicking create button now In right side there is solution Explorer. 

In that right click on your project name and click on add > Service Reference . You will get the following 

window : 

Note: before executing the code make sure that the web service is 

deployed. 



  
 / 

  

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Here in address bar paste the wsdl url the same which is used I python code. And press go button . agter set 

the namespace In my case I am letting is as it is then press ok button 

3] now in code write the following line as shown in image: 

https://study.cscornersunitarai.com/
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Here type: 

Using your_projectname . your_serviceReference_name ; 

4] now write the code as shown in the following image: 
 
 
 
 
 
 
 
 
 
 
 

 
Note: 

Here my webservice class name is conv and convClient is my webservice client class name 

and FtoC is method name as shown you can also check your own: 

5] when you run the above code you get the following output: 
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Create a Simple REST Service 

 

 
Practical-03A 

 

 

• Demonstrate CRUD operations with suitable database using RESTful Web service. 

1. To start the Java DB Database from NetBeans, perform the following steps. 

Click Services tab -> Expand Databases node. ->Right-click Java DB icon. 

->Select Start Server 
 
 
 
 
 
 
 
 
 
 

 
2. To create playerDB database, perform the following steps: 

a. Right-click Java DB icon, select Create Database. 
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b. Enter the following information for the database: 

Database Name: playerDB 

User Name: john 

Password: john 

Confirm Password:john 

c. Click OK. 

3. To connect to the newly created database playerDB, perform the following steps 

a. Right-click jdbc:derby://localhost:1527/playerDB connection. 

b. Select Connect. 

4. Create tables and populate them with data in playerDB database. 

a. In NetBeans select File > Open File. 

b. In the file select playersDB.sql. 

c. Click Open. The script automatically opens in the SQL Editor. 

5. Examine the contents of the database. 

a. In the Services window, expand the jdbc:derby://localhost:1527/playerDB connection under 

the Databases node. 
b. Right-click the connection and select Refresh. 

c. Expand the john schema. You see the nodes for Tables, Views, and Procedures. d. Expand 

the Tables node to see the PLAYER and TEAM tables. e. Right-click the 

PLAYER table node and select View Data. 

Player server 

To create RESTful Web Services, you need a Java Web application project. In the below section you will 
create a demo Java web project, PlayerServer. 

To create new Java Web Project, select File -> New Project -> Java web -> Web Application. 

Generating web service 

To generate RESTful Web Services do the following: 

1.Right-click the PlayerServer and choose New > Other > Web Services > RESTful Web Services from 
Database. The New RESTful Web Service wizard opens on the Database Tables panel. 
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3. Next select "New Data Source" from the Drop-down list. 

2. In the Database Tables window, select Data Source. 
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a. In the Create Data Source Window, enter the following information: 

o JNDI name: jdbc/playerDB 

o Database connection : select jdbc:derby://localhost:1527/playerDB[john on JOHN] 

b. Click OK. 
 
 
 
 
 
 
 
 
 
 

 
The PLAYER and TEAM tables are displayed under the Available Tables column. 

c. Click Add All. The PLAYER and TEAM tables are displayed under the Selected Tables column. 
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d. Click Next. 

 
4. In the Entity Classes window, complete the following steps: 

a. Enter the package name as com.playerentity. 

b. Click Next. 

 
5. In the Generated Classes Window, click Finish with default values. 

 
Test RESTful web Services 

1. To Generate Web Services Test client, complete the following steps. 
a. Select PlayerServer project. 
b. Right-click and select Test RESTful Web Services. 

2. Select "Web Test Client in project" and click Browse. 

3. a. In the Select Project dialog box, select PlayerServer and click OK. 

b. Configure Rest Test Client window is displayed, click OK. 
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Player Client 
To create new Java Project, select File > New Project >Playerclient 

Generating Entity Classes from Database 

Implementing CRUD operations on the database, requires creation of Entity Classes to 
communicate with the database. The following section demonstrates how to create Entity 
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Classes from database. 

1. Right-click PlayerClient Project and select New > Entity Classes From Database. 
 
 
 
 
 
 
 
 
 

 
2. a. In the Database Tables window, Database Connection field 
select jdbc:derby://localhost:1527/playerDB[john on JOHN] from the drop-down list. 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
You see PLAYER and TEAM tables in Available Tables category 
b. Click Add All 
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You see both the tables PLAYER and TEAM in Selected Tables Category. 
c. Click Next 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
3. In the Entity classes Window, enter the Package Name as playerentities and click Next. 
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Create Client 

Complete the following steps to create RESTful client in PlayerClient project. 

a. Right-click the PlayerClient and choose New > Other > Web Services > RESTful Java Client. 

b. Click Next. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
1. a.Enter the following details for the fields in the New Restful Java Client window : 
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b. Select PlayerServer. 
c. Expand the PlayerServer application. 
d. Select PlayerFacadeREST[com.playerentity.player]. 

• Class Name: CreatePlayerJerseyClient 

• Package: playerClient 

• Select the REST resource: From Project and Click Browse. 
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2. Add the main method. 

public static void main(String[]args){ 

CreateClient client1 = new CreateClient(); 

ClientResponse response = client1.findAll_XML(ClientResponse.class); 

 
GenericType<List<Player>> genericType = new GenericType<List<Player>>(){}; 

List<Player> data = new ArrayList<Player>(); 

data = (response.getEntity(genericType)); 

 
Player p = new Player(); 

p.setFirstname("Harry"); 

p.setId(30); 

p.setJerseynumber(60); 

p.setLastname("Potter"); 

p.setLastspokenwords("Thanks to my fans"); 
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client1.create_XML(p); 

} 
 
 
 
 
 
 
 
 
 
 

 
Read Client 

public static void main(String[]args){ 

ReadClient client1 = new ReadClient(); 

ClientResponse response = client1.findAll_XML(ClientResponse.class); 

GenericType<List<Player>> genericType = new GenericType<List<Player>>(){}; 

List<Player> data = new ArrayList<Player>(); 

data = (response.getEntity(genericType)); 

System.out.println("Retreiving and Displaying Player Details"); 

for(Player players:data){ 

System.out.println("FirstName:"+players.getFirstname()); 

System.out.println("PlayerID:"+players.getId()); 

System.out.println("JerseyNo:"+players.getJerseynumber()); 

} 

System.out.println("Data Retreived!!"); 

} 
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Delete Client 

public static void main(String[]args){ 

DeleteClient client1 = new DeleteClient(); 

client1.remove("1"); 

} 
 
 
 
 
 
 
 
 
 
 
 

 
Update Client 

public static void main(String[]args){ 

UpdateClient client1 = new UpdateClient(); 
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System.out.println("Last Spoken Words: "+player.getLastspokenwords()); 

player.setJerseynumber(100); 

player.setLastspokenwords("I will be retiring soon"); 

client1.edit_XML(player); 

} 

ClientResponse response = client1.find_XML(ClientResponse.class, "2"); 

GenericType<Player>genericType = new GenericType<Player>(){}; 

Player player = response.getEntity(genericType); 

System.out.println("First Name: "+player.getFirstname()); 

System.out.println("PlayerId: "+player.getId()); 

System.out.println("JerseyNo: "+player.getJerseynumber()); 

System.out.println("Last Name: "+player.getLastname()); 
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Practical No. 3B 

 
• Develop Micro-blogger application (like Twitter) using RESTful Web services. 

Blogger Server 
 

Blogger Client 
Create Client 
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public static void main(String[]args){ 
CreateClient client1 = new CreateClient(); 
ClientResponse response = client1.findAll_XML(ClientResponse.class); 
GenericType<List<Bloggerdb>> genericType = new GenericType<List<Bloggerdb>>(){}; 
List<Bloggerdb> data = new ArrayList<Bloggerdb>(); 
data = (response.getEntity(genericType)); 
Bloggerdb b = new Bloggerdb(); 
b.setMessageId(4); 
b.setContent("Draco the Slytherine Champion"); 
b.setUsername("Draco"); 
b.setPassword("Malfoy"); 
client1.create_XML(b); 

} 
 
 
 
 
 
 
 
 
 
 

 
Update Client 
public static void main(String[]args){ 

UpdateClient client1 = new UpdateClient(); 
ClientResponse response = client1.find_XML(ClientResponse.class, "1"); 
GenericType<Bloggerdb>genericType = new GenericType<Bloggerdb>(){}; 
Bloggerdb b = response.getEntity(genericType); 
System.out.println("Message id:"+b.getMessageId()); 
System.out.println("Content:"+b.getContent()); 
System.out.println("Username:"+b.getUsername()); 
System.out.println("Password:"+b.getPassword()); 
b.setContent("I love food"); 
client1.edit_XML(b); 

} 
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Delete Client 
public static void main(String[]args){ 

DeleteClient client1 = new DeleteClient(); 
client1.remove("4"); 
System.out.println("Successfully Deleted!!"); 

} 
 
 
 
 
 
 
 
 

 
Read Client 
public static void main(String[]args){ 

ReadClient client1 = new ReadClient(); 
ClientResponse response = client1.findAll_XML(ClientResponse.class); 
GenericType<List<Bloggerdb>> genericType = new GenericType<List<Bloggerdb>>(){}; 
List<Bloggerdb> data = new ArrayList<Bloggerdb>(); 
data = (response.getEntity(genericType)); 
System.out.println("Retreiving and Displaying Player Details"); 
for(Bloggerdb b:data){ 

System.out.println("Content: "+b.getContent()); 
System.out.println("Username: "+b.getUsername()); 
System.out.println("Password:"+b.getPassword()); 

} 
System.out.println("Data Retreived!!"); 
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} 
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Develop application to consume Google’s search / Google’s Map RESTful Web 

service. 

 
Practical-4 
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• Develop application to consume Google’s search / Google’s Map RESTful Web service. 
1. First of all we need to create an Java Web Application with any name, let it be GoogleMap here using 
Netbeans IDE. 
2. The code inside the input.jsp will be similar to this input.jsp Input.jsp 
<%@page contentType="text/html" pageEncoding="UTF-8"%> 

<!DOCTYPE html> 

<html> 

<head> 

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"> 

<title>JSP Page</title> 

</head> 

<body> 

<form action="index.jsp"> 

<pre> 

Enter latitude:<input type="text" name="t1" /> 

Enter longitude:<input type="text" name="t2" /> 

<input type="submit" value="Show" /> 

</pre> 

</form> 

</body> 

</html> 

 
3. Before running the application we need the Google API key. The steps are shown here: - Visit Google 
APIs Console (https://console.developers.google.com, you have to login with your Google account). 
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- Create a new API Project. 
 
 
 
 
 
 
 
 
 
 
 
 

 
- Enter the name to your project. 
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- Enable the Google Maps API V3. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
4. Create another file index.jsp 

Index.jsp 
<%@page contentType="text/html" pageEncoding="UTF-8"%> 

<!DOCTYPE html> 

<html> 

<head> 

<style> 
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<% 

double lati=Double.parseDouble(request.getParameter("t1")); 

double longi=Double.parseDouble(request.getParameter("t2")); 

%> 

<h3> Google Maps </h3> 

<div id="map"></div> 

<script lang="javascript"> 

function initMap() { 

var info={lat: <%=lati%>, lng: <%=longi%>}; 

var map = new google.maps.Map(document.getElementById('map'), 

{ 

zoom: 4, center: info 

}); 

var marker = new google.maps.Marker({ position: 

info, 

map: map 

}); 

#map { 

height: 400px; 

width: 100%; 

} 

</style> 

</head> 

<body> 

} 

</script> 

<script async defer 

src="put your key here"> 
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</script> 

</body> 

</html> 
 
 
 

 

Output :- 
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Practical-5 

 

 
 
 
 
 
 
 
 

 
Practical-6 

 
 

 
MTOMClient 
Index.jsp 
<%@page import="java.io.BufferedOutputStream"> 
<%@page import="java.io.FileOutputStream"> 
<%@page import="java.io.FileInputStream"> 
<%@page import="java.io.BufferedInputStream"> 
<%@page import="javax.imageio.stream.FileImageInputStream"> 
<%@page import="java.io.File"> 
<%@page import="javax.xml.ws.soap.MTOMFeature"> 
<%@page contentType="text/html" pageEncoding="UTF-8"> 
<!DOCTYPE html> 
<html> 
<head> 
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"> 
<title>JSP Page</title> 
</head> 
<body> 

Installation and Configuration of virtualization using KVM 

Develop application to download image/video from server or upload image/video 

to server using MTOM techniques 
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<%-- start web service invocation --><hr/> 
<% 
try { 
pkg.ImageWS_Service service = new pkg.ImageWS_Service(); 
pkg.ImageWS port = service.getImageWSPort(new MTOMFeature(60000)); 
// TODO initialize WS operation arguments here 
String filePath="c:/msc/ABC.jpg"; 
File file=new File(filePath); 
FileInputStream fis=new FileInputStream(file); 
BufferedInputStream bis=new BufferedInputStream(fis); 
java.lang.String filename = file.getName(); 
byte[]imageBytes=new byte[(int)file.length()]; 
bis.read(imageBytes); 
port.upload(filename, imageBytes); 
bis.close(); 
out.println("File uploaded :"+filePath); 
} catch (Exception ex) { 
// TODO handle custom exceptions here 
} 
> 
<%-- end web service invocation --><hr/> 

 
<%-- start web service invocation --><hr/> 
<% 
try { 

 
pkg.ImageWS_Service service = new pkg.ImageWS_Service(); 
pkg.ImageWS port = service.getImageWSPort(); 
// TODO initialize WS operation arguments here 
java.lang.String filename = "ABC.jpg"; 
String filePath="c:/msc/download/"+filename; 
// TODO process result here 
byte[] fileBytes = port.download(filename); 
FileOutputStream fos=new FileOutputStream(filePath); 
BufferedOutputStream bos=new BufferedOutputStream(fos); 
bos.write(fileBytes); 
bos.close(); 
out.println("File downloaded"+filePath); 
} catch (Exception ex) { 
// TODO handle custom exceptions here 
} 
> 
<%-- end web service invocation --><hr/> 
</body> 
</html> 
MTOMServer 
ImageWS.java 
package mypkg; 
import java.io.*; 
import javax.jws.Oneway; 
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import javax.jws.WebService; 
import javax.jws.WebMethod; 
import javax.jws.WebParam; 
import javax.xml.ws.soap.MTOM; 
@MTOM(enabled=true,threshold=60000) 
@WebService(serviceName = "ImageWS") 
public class ImageWS { 
@WebMethod(operationName = "upload") 
@Oneway 
public void upload(@WebParam(name = "Filename") String Filename, @WebParam(name = 
"ImageBytes") byte[] ImageBytes){ 
String filePath="C:/MSC/upload/"+Filename; 
try 
{ 
FileOutputStream fos=new FileOutputStream(filePath); 
BufferedOutputStream bos=new BufferedOutputStream(fos); 
bos.write(ImageBytes); 
bos.close(); 
System.out.println("Recieved file :"+filePath); 
} 
catch(Exception ex) 

 
{ 
System.out.println(ex); 
} 
} 
@WebMethod(operationName = "download") 
public byte[] download(@WebParam(name = "Filename") String Filename) { 
String filePath="C:/MSC/upload/"+Filename; 
System.out.println("Sending file :"+filePath); 
try 
{ 
File file=new File(filePath); 
FileInputStream fis=new FileInputStream(file); 
BufferedInputStream bis=new BufferedInputStream(fis); 
byte[] fileBytes=new byte[(int)file.length()]; 
bis.read(fileBytes); 
bis.close(); 
return fileBytes; 
} 
catch(Exception ex) 
{ 
System.out.println(ex); 
} 
return null; 
} 
} 
Output: 
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Practical-07 
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FOSS Cloud Installation 

Steps: 

1. Choose your keymap. 2. Confirm that you want to start: yes 

3. Choose Demo-System: 1 

4. Choose a Block-Device: sda 

5. Confirm that you want to continue: yes 

6. Confirm that you want to continue: yes 

7. Choose the network interface: eth0 

8. Choose if you want to use automatic network configuration: Yes 

9. Reboot your system: yes 

10. Login as root and run "fc-node-configuration -n demo-system --password admin" 

Note :- Above mentioned steps aren’t mandatory you can start with the installation process of 

virt-viewer as shown below. 

1. Install virt-viewer. 

2. Install spice-client.0.6.3. 

3. Open Browser. 

• Once you open browser then on the search type, 192.168.21.36 

Implement FOSS-Cloud Functionality VSI (Virtual Server Infrastructure) 

Infrastructure as a Service (IaaS), Creating Virtual Machine or Storage 
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• Uploading ISO files to Foss cloud 

Go to virtual machine→Profile→ Upload ISO file→file name 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Now choose the ubuntu-16.04.5-desktop-i386 iso-file from the FOSS cloud folder. Then, give 
your desired file name to it and click on the upload button. 
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10. Choose clock offset (normally Windows is "localtime" and Linux is "utc") 

 
 
 
 
 
 
 
 
 
 
 
 

 
Once done with the upload process go to the create section in profiles. 

Creating a Profile 

The profile creates the relationship between the ISO file and the FOSS-Cloud. 

1. Open Virtual Machines 

2. Choose VM-Profiles 

3. Choose the right Base Profile 

4. Choose the right architecture (Windows only x86_64) 

5. Chose the language (it is a information - not keyboard relevant) 

6. Choose the ISO file (which you gave in file name tab) 

7. Fill out name and description 

8. Choose the amount of memory and volume capacity 

9. Choose amount of CPU 
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Now, we will create a VM template. 

Creating Template 

1. Choose the profile you have prepared before. 

2. Add the VM-pool and one or more nodes, where you will run this VM (when the chosen VM- 
pool has only one node assigned, you don't have a choice) 

3. You can change all the other information you have entered before 

Click on "create" and the template is ready for installing the guest operating system. 
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Once you create your virtual machine template you will be able to see your VM template. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
As you can see the last row of Display column our template is created. 

 

 
To update your template status, click on the green arrow. 
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Now click on Use Template in Action column of your corresponding template. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Just after clicking on, it a pop up would appear to Open remote-viewer? click on Open-remote- 
viewer button, you will see the following screen. 
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2. Further permissions tab will open then click yes, and a regedit editor will get open. 

3. In the Registry Editor a list of directories would appear, in those lists of directories search 
for the spice directory. 

4. Keep on expanding the spice directory until you reach the command section. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Note :- If you don't see the above screen follow the below given steps. 

1.First press window + r, then type regedit and click ok. 
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5. Then click on the default file and a pop up will appear, then you have to paste the path 
C:\Users\ADMIN\AppData\Local\virt-viewer\bin in the value data and also type %1 in last. 
Once done the above screen will appear. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Finally, after clicking on remote viewer button a command line come where a graphical control 
loading and getting connected will be displayed and then finally the ubuntu will get open. 

On opening of ubuntu click on try ubuntu. Now, you can use ubuntu on your virtual machine. 
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Practical-08 

 

 
Software development Kits can be made available in the Virtual Machines that can be implemented 

as Platform as a Service. 

Installationof Netbeans, Eclipse, Visual Studio and DBMS can be done in the appropriate Virtual 

 
Implement FOSS-Cloud Functionality - VSI Platform as a Service (PaaS) 
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Aim: Implement FOSS-Cloud Functionality VSI Software as a Service (SaaS) 

Applications created and deployed in the virtual machines can be accessed by outside world. 

This can be implemented as Software as Service. 
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Practical No 1 
By Chandan 

Aim: Define a simple services like Converting Rs into Dollar and Call it from different 

platform like JAVA and .NET 

 

Solution: 

 

currency_converter.py 

from flask import Flask, request, jsonify 

app = Flask( name ) 

# Conversion rate: 1 INR = 0.012 USD (example rate) conversion_rate = 

0.012 

@app.route('/convert', methods=['GET']) def 

convert_currency(): 

inr = request.args.get('inr') if 

inr: 

try: 

inr_value = float(inr) 

usd_value = inr_value * conversion_rate return 

jsonify({"INR": inr_value, "USD": usd_value}) 

except ValueError: 

return jsonify({"error": "Invalid INR amount"}), 400 

return jsonify({"error": "INR amount missing"}), 400 

if   name == '  main  ': app.run(debug=True) 

 

CurrencyConverterClient.java 

import java.io.BufferedReader; import 

java.io.InputStreamReader; import 

java.net.HttpURLConnection; import 

java.net.URL; 

import java.util.Scanner; 

public class CurrencyConverterClient { 

public static void main(String[] args) { 

Scanner scanner = new Scanner(System.in); 

System.out.print("Enter amount in INR: "); String 

inrAmount = scanner.nextLine(); // User input 

try { 

String urlString = "http://127.0.0.1:5000/convert?inr=" + inrAmount; 



URL url = new URL(urlString); 

HttpURLConnection conn = (HttpURLConnection) url.openConnection(); 

conn.setRequestMethod("GET"); 

conn.setRequestProperty("Accept", "application/json"); 

if (conn.getResponseCode() != 200) { throw new 

RuntimeException("Failed : HTTP error code : " 

+ conn.getResponseCode()); 

} 

BufferedReader br = new BufferedReader(new InputStreamReader( 

(conn.getInputStream()))); 

String output; 

System.out.println("Currency Conversion:"); while 

((output = br.readLine()) != null) { 

System.out.println(output); 

} 

conn.disconnect(); 

} catch (Exception e) { 

e.printStackTrace(); 

} 

} 

} 

 

Output: 

Now take new terminal 

 



Practical No 2 
By Chandan (java 8v) 

 
Aim: Create a Simple SOAP service 

 

Solution: 

Step 1: Download JDK 8 

 

Step 2: Create New Project in Intellij Idea & Select Java 8 & Maven Structure 

 

CalculatorServiceImpl.java 

package com.example.soap; 

 

import javax.jws.WebService; 

 

@WebService(endpointInterface = 

"com.example.soap.CalculatorService") public class 

CalculatorServiceImpl implements CalculatorService { 

 

@Override public int 

add(int num1, int num2) { 

return num1 + num2; 

} 

} 

 

CalculatorService.java 

package com.example.soap; 

import javax.jws.WebService; 

@WebService 



public interface CalculatorService 

{ public int add(int num1, int 

num2); 

} 

 

CalculatorPublisher.java 

package com.example.soap; 

import javax.xml.ws.Endpoint; 

public class CalculatorPublisher { 

public static void main(String[] args) { 

// Publishing the service at a specific URL 

Endpoint.publish("http://localhost:8080/calculator", new CalculatorServiceImpl()); 

System.out.println("Service is running at http://localhost:8080/calculator"); 

} 

} 

 

 

 

 

 

CalculatorClient.java 

package com.example.soap; 

 

import 

javax.xml.namespace.QName; 



import javax.xml.ws.Service; 

import java.net.URL; 

 

public class CalculatorClient { 

 

public static void main(String[] args) throws Exception { 

// URL to the WSDL 

URL url = new URL("http://localhost:8080/calculator?wsdl"); 

 

// Correct QName based on the WSDL (Check the actual service name) 

QName qname = new QName("http://soap.example.com/", 

"CalculatorServiceImplService"); 

 

// Creating service instance 

Service service = Service.create(url, qname); 

 

// Getting the port and invoking the method 

CalculatorService calculator = 

service.getPort(CalculatorService.class); 

 

int result = calculator.add(10, 20); 

System.out.println("Result: " + result); 

} 

} 

 

Output: 
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By Chandan 

Aim: Create a Simple REST Service. 

Solution: 

add_numbers.py 

from flask import Flask, request, jsonify 

app = Flask( name ) 

# Route to add two numbers 

 

@app.route('/add', methods=['GET']) 

def add_numbers(): 

# Get numbers from query parameters 

num1 = float(request.args.get('num1')) 

num2 = float(request.args.get('num2')) 

# Calculate the sum 

result = num1 + num2 

# Return the result as JSON 

return jsonify({"result": result}) 

 

if  name == ' main ': 

app.run(debug=True) 

 

 

Output: 
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Aim: 

Develop an application to consume Google‘s search / Google‘s Map RESTful Web 

service. 

 

Solution: 

 

Step 1: Search ―console cloud google‖ on chrome and sign up 
https://console.cloud.google.com 

Click on project and create new project 

 
Give project name and then click create 

 

 

You can see your project by clicking bell icon 

 

Step 2: Click on bell icon and click ―select project‖ 



Once you select the project then click on top-left burger icon → Click ―APIs and 

Services‖ → Enabled APIs and services 

 

 

Search ―Custom search api‖ on search bar and click on first link 

In google cloud project you always have to specify which functionality you want to 

enable. 

Click on enable to enable custom search api 

This enable the custom search api for this particular project 
 

 

 

Step 3: Now you need to generate an api key to authenticate yourself from python. 

 

In the Api & Services section click on credentials→ click create credentials→Click API 

key 



 

 

Create a file as API_KEY in your project and paste api_key value in it 

Step 4: Create a search engine 

Go to google search programmable search engine → Open first website and click get 

started 

Give name to your search engine and select the "search the entire website ― and click 

create 

 



 

Step 5: Click ―go back to all search engine‖ → click on your search engine → Copy the 

search engine ID 

 
 

Create a new file on your project as SEARCH_ENGINE_ID and paste your search engine 

ID 

 

Download requests using pip3 install requests in the command line . 

Directory structure: 

 

 

 

 

 

 

 

 

 

 

 

 

Step 6: Get text results using google search 

Create a file main.py and write a below code in it 

Code: 



import requests 

 

# Replace with your actual API key and Search Engine ID 

API_KEY = 'Enter your Api Key' 

SEARCH_ENGINE_ID = 'Enter your Engine ID' 

 

search_query = 'ismail yusuf college' 

url = 'https://www.googleapis.com/customsearch/v1' 

params = { 

'q': search_query, 

'key': API_KEY, 

'cx': SEARCH_ENGINE_ID 

} 

 

# Send request to the API 

response = requests.get(url, params=params) 

 

# Get the response data in JSON format 

results = response.json() 

 

# Check if there are results and print the first result's link 

if 'items' in results: 

print(results['items'][0]['link']) 

else: 

print("No results found.") 
 

 

Output: 
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Aim: 

Installation and Configuration of virtualization using KVM. 

 

Solution: 

 

Step 1: Select Ubuntu platform Virtual Machine or Physical Ubuntu Machine 

recommended: go with Dual Boot 

 

Step 2: In case of Virtual Machine use execute these command 

―cd C:\Program Files\Oracle\VirtualBox― 

―VBoxManage modifyvm ―ubu‖ –nested—hw-virt on‖ 

 

Step 3: open settings 

Step 4: Give minimum 6 Processors & Nested VTX Should ON through above command 

 



Step 5: open terminal & run this command to check processors 

$ egrep -c ‗(vm|svm)‘ /proc/cpuinfo 

 

 

Step 6: $ kvm-ok 

 

Step 7: $ sudo apt-get install -y qemu-kvm virt-manager 

Step 8: $ sudo systemctl enable --now libvirtd 

$ sudo systemctl start --now libvirtd 

$ sudo systemctl status --now libvirtd 

 

Step 9: $ sudo usermod -aG kvm $USER 

$ sudo usermod -aG libvirt $USER 

 

Step 10: Search Virtual Machine and open 



 

 

Step 11: Click on File 

 

Step 12: Add Connection 

 

Step 13: QEMU/KVM user session 



Step 14: click on ―Connect‖ and then yes 

 

Step 15: now right click on ―user session‖ and create new virtual machine 

 

Step 16: Select 1
st
 option and then forward 



 

Step 17: Download ubuntu ISO File 16 & Click on Browse 

 

Step 18: Browse local 

Select ISO file and then forward 



 

Step 18: Allocate Memory & CPUs and then forward 

Step 19: Allocate Disk Space & then finish 
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By Chandan 

Aim: Develop application to download image/video from server or upload image/video to 

server using MTOM techniques. 

Solution: 

Using Flask 

Step 1: Create app.py file & Run 

app.py 

from flask import Flask, request, 

send_from_directory import os 

app = Flask( name ) 

# Namaste Bacho ! Uploads ke liye folder banane ka 

UPLOAD_FOLDER = 'uploads' 

os.makedirs(UPLOAD_FOLDER, exist_ok=True) 

# 1. File upload endpoint 

@app.route('/upload', 

methods=['POST']) def upload_file(): 

file = 

request.files.get('file') if 

file: 

file_path = os.path.join(UPLOAD_FOLDER, file.filename) 

file.save(file_path) 

return {"message": f"File '{file.filename}' uploaded successfully!"}, 200 

return {"error": "No file uploaded"}, 400 

# 2. File download endpoint 

@app.route('/download/<filename>', 

methods=['GET']) def download_file(filename): 

try: 

return send_from_directory(UPLOAD_FOLDER, filename, as_attachment=True) 

except FileNotFoundError: return 

{"error": "File not found"}, 404 

if  name == 

'  main  ': 

app.run(debug=True) 



 

After running this code it will automictically create uploads folder 

Step 2: Open postman and select method ―POST‖ 

Step 3: Enter url http://127.0.0.1:5000/upload & select Body & then select form-data and 

replace text With File 

 

Step 4: Click on Values and + New file from local machine 



Step 5: After selecting file click on send button 

Now u can see uploaded file in uploads folder 

 

Image file 
 



Using Real MTOM Technique 

Step 1: Open Intelijee and do the basic work as shown in the screenshots. 

Step 2: Give the example Group ID. 

 

Step 3: After creating, the app will look like this. 



Step 4: Now right-click on the example, and then left-click to create a new Java class. 

Name it as I‘m telling you. 

 

 

 

 

 

Step 5: You have to create all these classes one by one. 

 

 

Step 6: Now look at the code and type it correctly from the files one by one. 

 

FileService.java 

package com.example; 

 

import javax.jws.WebMethod; 

import javax.jws.WebService; 

import javax.xml.ws.soap.MTOM; 

 

@MTOM // Enable MTOM 

@WebService 

public interface FileService { 

@WebMethod 

String uploadFile(byte[] data, String fileName); 

@WebMethod 

byte[] downloadFile(String fileName); 

} 

 

FileServiceImpl.java 

package com.example; 

 

import javax.jws.WebService; 

import java.io.FileOutputStream; 

import java.io.IOException; 

import java.nio.file.Files; 

import java.nio.file.Paths; 

 

@WebService(endpointInterface = "com.example.FileService") 

public class FileServiceImpl implements FileService { 

 

private static final String FILE_DIRECTORY = 

"C:/Users/Chandan/Documents/chan/iyc/sem 6/CC 



EXP/soap/mtom/src/main/java/com/example"; // Update path as required 

 

@Override 

public String uploadFile(byte[] data, String fileName) { 

try (FileOutputStream fos = new FileOutputStream(FILE_DIRECTORY + 

fileName)) { 

fos.write(data); 

return "File uploaded successfully: " + fileName; 

} catch (IOException e) { 

e.printStackTrace(); 

return "File upload failed: " + e.getMessage(); 

} 

} 

 

@Override 

public byte[] downloadFile(String fileName) { 

try { 

return Files.readAllBytes(Paths.get(FILE_DIRECTORY + fileName)); 

} catch (IOException e) { 

e.printStackTrace(); 

return null; 

} 

} 

} 

 

FileServer.java 

package com.example; 

import javax.xml.ws.Endpoint; 

public class FileServer { 

public static void main(String[] args) { 

String serviceUrl = "http://localhost:8080/FileService"; 

Endpoint.publish(serviceUrl, new FileServiceImpl()); 

System.out.println("MTOM Service published at: " + serviceUrl); 

} 

} 

 

FileClient.java 

package com.example; 

 

import javax.xml.namespace.QName; 

import javax.xml.ws.Service; 

import java.io.File; 

import java.io.FileOutputStream; 

import java.net.URL; 

import java.nio.file.Files; 

public class FileClient { 



public static void main(String[] args) throws Exception { 

// Connect to the published service 

URL wsdlUrl = new URL("http://localhost:8080/FileService?wsdl"); 

QName qname = new QName("http://example.com/", 

"FileServiceImplService"); 

Service service = Service.create(wsdlUrl, qname); 

FileService fileService = service.getPort(FileService.class); 

 

// Upload a file 

File fileToUpload = new 

File("C:/Users/Chandan/Pictures/Screenshots/Screenshot 2025-01-18 203338.png"); // 

Adjust file path 

byte[] fileData = Files.readAllBytes(fileToUpload.toPath()); 

String uploadResponse = fileService.uploadFile(fileData, "uploaded.jpg"); 

System.out.println(uploadResponse); 

 

// Download a file 

byte[] downloadedData = fileService.downloadFile("uploaded.jpg"); 

String downloadPath = "C:/Users/Chandan/Documents/chan/iyc/sem 6/CC 

EXP/downloaded.jpg"; // Specify a full file path 

try (FileOutputStream fos = new FileOutputStream(downloadPath)) { 

fos.write(downloadedData); 

System.out.println("File downloaded successfully to: " + downloadPath); 

} 

} 

} 

Step 7: After writing the code and copying-pasting it, first open the FileServer and 

run it. Click on the run button under the current file. 



 

Step 8: Look kids, the run is successful. Open the server and client, then run them. 

 

 

Step 9: See kids, the file will be uploaded and downloaded using the MTOM 

technique. 

 

 

 Uploaded file will appear here. 

 Now, let‘s see the downloaded file. 
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Aim: Implement FOSS-Cloud Functionality VSI (Virtual Server Infrastructure) 

Infrastructure as a Service (IaaS), Storage 

Solution: 

Note: If your windows machine support then You can do this practical in windows otherwise install 

virtual box in Physical Dual Booted Ubuntu Machine and follow same steps except one step 

Step 1: Download Foss Cloud ISO 

Step 2: Create Virtual with the below configurations 

 



 

Step 3: Select Bridged Adapter 

Step 4: Turn off firewall 



 
 

For Linux: Execute ―ufw disable‖ in root user mode 

Step 5: Open Run cmd as administrative then execute the below commands 

―cd C:\Program Files\Oracle\VirtualBox― 

―VBoxManage modifyvm ―foss‖ –nested—hw-virt on‖ 

 

 

 

For Linux: You need to enable it manually by clicking on Enable Nested VT-x/AMD-V 



 

Step 6: Start the virtual Machine 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 7: Select 1
st
 option 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Hit Enter 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Yes 



 
 Select 1) Demo-System 

 Enter sda 

 

 Enter yes 



 

 Enter enp0s3 and then yes and then again yes for reboot 

Step 8: Boot from first Hard disk 

 



Step 9: Select FOSS-Cloud 

 

After this IP Address should come 



 

Step 10: Now Login with root and password admin 

Step 11: Execute fc-node-configuration -n demo-system -password admin 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Ifconfig and then note this ip address 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 12: Open Browser in your main machine and enter IP address of Foss Virtual Machine 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 13: Login with username ―admin‖ & password ―admin‖ 
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Aim: Implement FOSS-Cloud Functionality - VSI Platform as a Service (PaaS) 

 

Solution: 

Step 1: Login Foss Cloud 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 2: Expand Virtual Machine Tab 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 3:Upload ISO File of Ubuntu 16 



 

 Select & upload 
 

After uploading give File name 

 



 

Step 4: Create VM Profile 



 Now select BaseProfile [Your OS Windows or Linux]  x86_64 en-US 

then give Name ,Description, memory, Vol capacity, CPU & localtime then 

create 
 



 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 5: Now Navigate to VM Template then click on create after that select Profile 

[os Windows or Linux]  [VM Name]  x86_64en-US and then select Vmpool & 

number of display 1 and create 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 6: Click on Green Arrow  to start VM 
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Aim: Using AWS Flow Framework develop application that includes a simple 

workflow. Workflow calls an activity to print hello world to the console. It must define 

the basic usage of AWS Flow Framework, including defining contracts, implementation 

of activities and workflow coordination logic and worker programs to host them 

Solution: 

Note: AWS is paid so there we using its kind of 1 type of alternative neon DB which uses 

AWS Cloud service and give us some free storage which built on AWS 

Step 1: Create a account neon db 
 

Step 2: Verify email 

 

Step 3: Chose Cloud Service Provider ―AWS‖ 



 
Now we got our connection url 

 

Step 4: Go to SQL Editor and create a Table by executing command which is 

mentioned in screenshot 



 After writing click on Run 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 Now table created 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Now inset a value in able by entering below Query in Screenshot and then run 



 

 

 

 

 

 

 

 

 

 

 Now Value is inserted into table now we will fetch that value in console 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 5: Create a python file and run 

Neondb.py 

import psycopg2 

 

# Replace these with your Neon database credentials 

DB_HOST = "ep-royal-sound-a5vze9rq-pooler.us-east- 

2.aws.neon.tech" 

DB_NAME = "neondb" 

DB_USER = "neondb_owner" 

DB_PASS = "npg_Ztv1oYdsI3Sq" 

try: 

# Connect to the Neon database 

connection = psycopg2.connect( 

host=DB_HOST, 

database=DB_NAME, 

user=DB_USER, 

password=DB_PASS 

) 

 

# Create a cursor object 



cursor = connection.cursor() 

 

# Query to fetch "Hello World" from the database 

cursor.execute("SELECT message FROM greetings WHERE id = 

1;") result = cursor.fetchone() 

 

# Print the result 

print("Fetched from Neon DB:", result[0]) 

 

except Exception as e: print("Error 

connecting to the database:", e) 

finally: if connection: 

cursor.close() 

connection.close() 

 

 

Output: 
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Aim: 

Implementation of Openstack with user and private network creation. 

 

Solution: 

Step 1: sudo snap install microstack --beta 

 
 

Step 2: snap list microstack 

 

Step 3: sudo microstack init --auto --control 

 

 

Step 4: microstack.openstack --version 

 



Step 5: sudo snap get microstack config.credentials.keystone-password 

 

 

Step 6: ip a 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 7: now open Browser and enter https://yourip 

https://192.168.90.133 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 8: Login user name: admin & password from them terminal which got through 

previous command 



 


